Decreased performance

Incident Report for 1map

Resolved

This incident has been resolved.
Posted May 09, 2025 - 13:00 CAT

Update

We are continuing to investigate this issue.
Posted May 09, 2025 - 11:01 CAT

Investigating

There seems to be something causing slow load speeds on the map. We are investigating the cause of the problem.
Posted May 09, 2025 - 10:53 CAT
This incident affected: 1map Main and 1map Mobile.